If you encounter the error 'Missing year or reg group for pupil name'. You will need to correct the data and re-attempt the upload, it indicates missing data in the upload file and requires some correction.
Error:
When reviewing the Upload History section in ParentPay you might encounter the following error message:
Missing year or reg group for <pupil name>
Cause:
There is missing mandatory information in the data you are uploading into ParentPay. There are several possible causes for this:
- this is a pre-admission pupil who never started at the school
- this is a leaver from the school, for example, last year's Year 6
- the pupil is set to begin later in the term
Solution:
Taking the time to understand who the pupil in error is usually helps identify the cause of the problem. For example, the pupil recently left your school to move to their secondary phase, but an error in taking them off role has left them in your upload data.
In almost all cases these issues need to be resolved in your MIS before you re-attempt the upload into ParentPay.
- Check that the pupil listed in the error message has a registration group correctly allocated.
- If they are a leaver check that they have been processed correctly as they should not appear in the data that is sent to ParentPay.
- If they are a new starter but have not yet started at the school, they will need to be taken out of your enrolled pupils until they are ready to be allocated to a year group and registration. ALL pupils must have both a year group and registration allocated to be uploaded into ParentPay. These can be changed in the future by correcting the information in your MIS and re-uploading.